Hi, On Friday 06 February 2009, Sergei Shtylyov wrote: > Hello. > > Bartlomiej Zolnierkiewicz wrote: > > >>>>> +#include <asm/ide.h> > >>>>> > >>>> Did you try checkpatch.pl? > >>>> > >>> Sure. > >>> > >>> This driver uses stuff from <asm-mips/ide.h>. > >>> > >>> [ I guess I could put '-mips' there to silence warnings on tx493{8,9}.c, > >>> however I don't know of the way to get rid of ide-io-std.c's one... ] > >>> > >> BTW, tx4939ide_{in,out}put_data_swap and > >> tx4939ide_{in,out}put_data_swap do exactly same thing. > >> > >> If byte-swapped version of ide_{in,out}put_data() were available by > >> ide core, they can be used instead. The byte-swapped version of > >> default_tp_ops would much helps such queer big-endian platforms. Is > >> it worth to bloat ide core? ;-) > >> > > > > Seems to be a good idea and it may also help some other host drivers > > (ide-h8300.c?). > > > > I'm not sure we need to carry the extra little used code just to help > some exotic driver. It doesn't seem like we would need to carry any extra extra code for host drivers that don't need it because we have flexible Kconfig language to take care of such cases, i.e. ... config CONFIG_IDE_BE_IO bool ... config BLK_DEV_IDE_TX4938 tristate "TX4938 internal IDE support" depends on SOC_TX4938 select IDE_TIMINGS select IDE_BE_IO ... Thus having be_tp_ops would decrease code duplication [ I now also see that m68k host drivers would benefit from it. I haven't noticed it before because readw()/writew() are redefined in <asm-m68k/ide.h> ] and decrease total IDE subsystem maintainance costs. Thanks, Bart -- To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html