Tejun Heo <htejun@xxxxxxxxx> wrote: > libata has been using mix of jiffies and msecs for time druations. > This is getting confusing. As writing sub HZ values in jiffies is > PITA and msecs_to_jiffies() can't be used as initializer, unify unit > for all time durations to msecs. So, durations are in msecs and > deadlines are in jiffies. ata_deadline() is added to compute deadline > from a start time and duration in msecs. > > While at it, drop now superflous _msec suffix from arguments and > rename @timeout to @deadline if it represents a fixed point in time > rather than duration. > > Signed-off-by: Tejun Heo <htejun@xxxxxxxxx> [...] > +static inline unsigned long ata_deadline(unsigned long from_jiffies, > + unsigned long timeout_msecs) ^^^^^^ Wouldn't that be against the newly adopted convention? Just a thought. Regards, Elias -- To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html