On Saturday 23 February 2008, Sam Ravnborg wrote: > hpt366: fix section mismatch warnings > > Fix following warnings: > WARNING: o-sparc64/vmlinux.o(.data+0x195a38): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt370 > WARNING: o-sparc64/vmlinux.o(.data+0x195a40): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt370a > WARNING: o-sparc64/vmlinux.o(.data+0x195a48): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt372 > WARNING: o-sparc64/vmlinux.o(.data+0x195a50): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt372n > > Replace a static array with a small switch resulting in > more readable code. > Mark the pci table __devinitconst. > > A lot of variables are const but annotated __devinitdata. > Annotating them __devinitconst would cause a section type > conflict error when build for 64 bit powerpc. > > Signed-off-by: Sam Ravnborg <sam@xxxxxxxxxxxx> > Cc: Bartlomiej Zolnierkiewicz <bzolnier@xxxxxxxxx> > Cc: Sergei Shtylyov <sshtylyov@xxxxxxxxxxxxx> > --- thanks, applied > The first patch I posted caused a section type conflict when > build for 64 bit powerpc. The actual cause of this is know and unavoidable > when we start to declare variables const. > The patch attached is much simpler as the transition from __devinitdata > to __devinitconst turned out to be bogus. Weird, I thought that the main purpose of __devinitconst was to replace const + __devinitdata? - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html