alan@xxxxxxxxxxxxxxxxxxx wrote:
+ /* We don't really care */
+ dev->pio_mode = XFER_PIO_0;
+ dev->dma_mode = XFER_MW_DMA_0;
+ /* We do need the right mode information for DMA or PIO
+ and this comes from the current configuration flags */
+ /* FIXME: at some point in the future this should become
+ a library helper which reads the disk modes from the
+ disk as well */
This sounds like a comment bug?
We already have the IDENTIFY [PACKET] DEVICE page with this info...
+static int all_generic_ide; /* Set to claim all devices */
Maybe a better name is 'claim_all'?
+static struct pci_driver pata_generic_pci_driver = {
+ .name = DRV_NAME,
weird whitespace
+MODULE_AUTHOR("Alan Cox");
+MODULE_DESCRIPTION("low-level driver for generic ATA");
+MODULE_LICENSE("GPL");
+MODULE_DEVICE_TABLE(pci, pata_generic);
+MODULE_VERSION(DRV_VERSION);
Various symbols and strings seem to be confused as to whether this is
generic PATA or generic ATA.
Suggest either s/pata_/ata_/ or s/ata_/pata_/
ACK everything else
Jeff
-
: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html