Re: [PATCH] hugetlb: simplify hugetlb handling in follow_page_mask

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 08/30/22 09:44, Mike Kravetz wrote:
> On 08/30/22 09:06, Baolin Wang wrote:
> > Hi Mike,
> > 
> > On 8/30/2022 7:40 AM, Mike Kravetz wrote:
> > > During discussions of this series [1], it was suggested that hugetlb
> > > handling code in follow_page_mask could be simplified.  At the beginning
> > > of follow_page_mask, there currently is a call to follow_huge_addr which
> > > 'may' handle hugetlb pages.  ia64 is the only architecture which provides
> > > a follow_huge_addr routine that does not return error.  Instead, at each
> > > level of the page table a check is made for a hugetlb entry.  If a hugetlb
> > > entry is found, a call to a routine associated with that entry is made.
> > > 
> > > Currently, there are two checks for hugetlb entries at each page table
> > > level.  The first check is of the form:
> > > 	if (p?d_huge())
> > > 		page = follow_huge_p?d();
> > > the second check is of the form:
> > > 	if (is_hugepd())
> > > 		page = follow_huge_pd().
> > > 
> > > We can replace these checks, as well as the special handling routines
> > > such as follow_huge_p?d() and follow_huge_pd() with a single routine to
> > > handle hugetlb vmas.
> > > 
> > > A new routine hugetlb_follow_page_mask is called for hugetlb vmas at the
> > > beginning of follow_page_mask.  hugetlb_follow_page_mask will use the
> > > existing routine huge_pte_offset to walk page tables looking for hugetlb
> > > entries.  huge_pte_offset can be overwritten by architectures, and already
> > > handles special cases such as hugepd entries.
> > 
> > Could you also mention that this patch will fix the lock issue for
> > CONT-PTE/PMD hugetlb by changing to use huge_pte_lock()? which will help
> > people to understand the issue.
> 
> Will update message in v2.  Thanks for taking a look!
> 

One additional thought, we 'may' need a separate patch to fix the locking
issues that can be easily backported.  Not sure this 'simplification' is
a good backport candidate.
-- 
Mike Kravetz



[Index of Archives]     [Linux Kernel]     [Sparc Linux]     [DCCP]     [Linux ARM]     [Yosemite News]     [Linux SCSI]     [Linux x86_64]     [Linux for Ham Radio]

  Powered by Linux