Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
- To: Christoph Hellwig <hch@xxxxxx>, iommu@xxxxxxxxxxxxxxxxxxxxxxxxxx
- Subject: Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_
- From: Michael Ellerman <mpe@xxxxxxxxxxxxxx>
- Date: Tue, 02 Jan 2018 20:45:30 +1100
- Cc: linux-mips@xxxxxxxxxxxxxx, linux-ia64@xxxxxxxxxxxxxxx, linux-sh@xxxxxxxxxxxxxxx, sparclinux@xxxxxxxxxxxxxxx, Guan Xuetao <gxt@xxxxxxxxxxxxxxx>, linux-arch@xxxxxxxxxxxxxxx, linux-s390@xxxxxxxxxxxxxxx, linux-c6x-dev@xxxxxxxxxxxxx, linux-hexagon@xxxxxxxxxxxxxxx, x86@xxxxxxxxxx, linux-snps-arc@xxxxxxxxxxxxxxxxxxx, adi-buildroot-devel@xxxxxxxxxxxxxxxxxxxxx, linux-m68k@xxxxxxxxxxxxxxx, patches@xxxxxxxxxxxxxxxx, linux-metag@xxxxxxxxxxxxxxx, linux-arm-kernel@xxxxxxxxxxxxxxxxxxx, Michal Simek <monstr@xxxxxxxxx>, linux-parisc@xxxxxxxxxxxxxxx, linux-cris-kernel@xxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx, linux-alpha@xxxxxxxxxxxxxxx, linuxppc-dev@xxxxxxxxxxxxxxxx
- In-reply-to: <20171229081911.2802-17-hch@lst.de>
- References: <20171229081911.2802-1-hch@lst.de> <20171229081911.2802-17-hch@lst.de>
Christoph Hellwig <hch@xxxxxx> writes:
> We want to use the dma_direct_ namespace for a generic implementation,
> so rename powerpc to the second best choice: dma_nommu_.
I'm not a fan of "nommu". Some of the users of direct ops *are* using an
IOMMU, they're just setting up a 1:1 mapping once at init time, rather
than mapping dynamically.
Though I don't have a good idea for a better name, maybe "1to1",
"linear", "premapped" ?
cheers
--
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
[Index of Archives]
[Linux Kernel]
[Sparc Linux]
[DCCP]
[Linux ARM]
[Yosemite News]
[Linux SCSI]
[Linux x86_64]
[Linux for Ham Radio]