On 25/02/2025 11:29, Arnd Bergmann wrote: > On Tue, Feb 25, 2025, at 11:08, Andy Shevchenko wrote: >> These result in a very small reduction in driver size, but at the cost >> of more complex build and slightly harder to read code. In the case of >> of_match_ptr() it also prevents use of PRP0001 ACPI based identification. >> In this particular case we have a valid ACPI/PNP ID that should be used >> in preference to PRP0001 but doesn't mean we should prevent that route. >> >> With this done, drop unneeded of*.h inclusions and __maybe_unused markers. >> >> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > > Acked-by: Arnd Bergmann <arnd@xxxxxxxx> > > For reference, see below for a couple of patches in this area that > I have sent in the past. Ideally I think we should try to fix these > all up and enable -Wunused-const-variable, which is useful in its > own right. > I tried to fix this in SPI, regulator and ASoC 2 years ago and Mark rejected such approach of dropping ACPI/of_match_ptr. AFAIU, Mark wants this to be fixed in more generic way, on the OF and ACPI common code, not per driver. SPI: https://lore.kernel.org/all/7a65d775-cf07-4393-8b10-2cef4d5266ab@xxxxxxxxxxxxx/ regulator: https://lore.kernel.org/all/20230310214553.275450-1-krzysztof.kozlowski@xxxxxxxxxx/ ASoC: https://lore.kernel.org/all/20230310214333.274903-1-krzysztof.kozlowski@xxxxxxxxxx/ Best regards, Krzysztof