On Tue, Feb 25, 2025 at 11:29:05AM +0100, Arnd Bergmann wrote: > On Tue, Feb 25, 2025, at 11:08, Andy Shevchenko wrote: > > These result in a very small reduction in driver size, but at the cost > > of more complex build and slightly harder to read code. In the case of > > of_match_ptr() it also prevents use of PRP0001 ACPI based identification. > > In this particular case we have a valid ACPI/PNP ID that should be used > > in preference to PRP0001 but doesn't mean we should prevent that route. > > > > With this done, drop unneeded of*.h inclusions and __maybe_unused markers. > > > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > > Acked-by: Arnd Bergmann <arnd@xxxxxxxx> Thank you! > For reference, see below for a couple of patches in this area that > I have sent in the past. Ideally I think we should try to fix these > all up and enable -Wunused-const-variable, which is useful in its > own right. Agree. > Your patch does not address a warning, but it's still a step > in that direction. Yeah, because the original code uses __maybe_unused markers. ... > Subject: [PATCH] [SUBMITTED 20240403] spi: remove incorrect of_match_ptr > annotations Was it applied (and the rest you provided here)? To me sounds like a good cleanup that should be applier sooner than later to move forward of getting rid of of_match_ptr()/ACPI_PTR() completely. -- With Best Regards, Andy Shevchenko