"smbus_alert" is a generic interrupt name for controllers, so document it. Introduce also "irq" for the primary interrupt. Signed-off-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> --- dtschema/schemas/i2c/i2c-controller.yaml | 16 ++++++++++++++++ 1 file changed, 16 insertions(+) diff --git a/dtschema/schemas/i2c/i2c-controller.yaml b/dtschema/schemas/i2c/i2c-controller.yaml index 7eb6b0f..da277a2 100644 --- a/dtschema/schemas/i2c/i2c-controller.yaml +++ b/dtschema/schemas/i2c/i2c-controller.yaml @@ -90,6 +90,22 @@ properties: low-pass analog filter). Typical value should be above the normal i2c bus clock frequency (clock-frequency). Specified in Hz. + interrupts: + description: + If not using interrupt-names, the first interrupt will be treated as the + primary interrupt for the controller. + + interrupt-names: + anyOf: + - {} # Any name is allowed. + - items: + enum: + - irq + - smbus_alert + description: + Generic names are "irq" for a primary interrupt and "smbus_alert" for + the SMBusAlert signal. Other names are left to individual bindings. + mctp-controller: type: boolean description: -- 2.43.0