Re: [PATCH 1/4] i2c: designware: Create shared header hosting driver name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 4/24/24 2:59 AM, Andy Shevchenko wrote:
Tue, Apr 23, 2024 at 04:36:19PM -0700, Florian Fainelli kirjoitti:
We have a number of drivers that reference the string "i2c_designware"
yet this is copied all over the places with opportunities for this
string being mis-used. Create a shared header that defines this as a
constant that other drivers can reference.

...

  #include <linux/i2c.h>
+#include <linux/i2c-designware.h>

Can it be hidden in the subfolder?

...

-#define DRIVER_NAME "i2c-designware-pci"
+#define DRIVER_NAME I2C_DESIGNWARE_NAME "-pci"

Oh, this makes all the things hard to read.

  /* Work with hotplug and coldplug */
-MODULE_ALIAS("i2c_designware-pci");
+MODULE_ALIAS(DRIVER_NAME);

I believe we shouldn't use MODULE_ALIAS() without real justification.

I think MODULE_ALIAS() is even needless here since this device is not added from another driver but loaded only for known PCI IDs in device table.




[Index of Archives]     [Linux GPIO]     [Linux SPI]     [Linux Hardward Monitoring]     [LM Sensors]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux