Hi Andy, > > + if (!(dev->flags & ACCESS_POLLING)) { > > Actually seems to me that is better to have in a separate helper and you > then can do here something like > > ret = i2c_dw_request_irq(...); > if (ret) > return ret; I find it a bit misleading because the first question that comes to mind upon reading such a line is, 'What if access is polling?' without looking inside the function. In this case, a more appropriate name would then be i2c_sw_request_irq_if_needed(). :) Andi