Re: [PATCH -next] I2C: Use helper function IS_ERR_OR_NULL()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Le 16/08/2023 à 11:46, Ruan Jinjie a écrit :

Use IS_ERR_OR_NULL() instead of open-coding it
to simplify the code.
rinfo->pinctrl = devm_pinctrl_get(&pdev->dev);
-	if (!rinfo->pinctrl || IS_ERR(rinfo->pinctrl)) {
+	if (IS_ERR_OR_NULL(rinfo->pinctrl)) {

Can the return of devm_pinctrl_get really be NULL?

Regards,

--

Yann




[Index of Archives]     [Linux GPIO]     [Linux SPI]     [Linux Hardward Monitoring]     [LM Sensors]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux