On Sat, May 6, 2023 at 12:29 PM Jiawen Wu <jiawenwu@xxxxxxxxxxxxxx> wrote: > On Saturday, May 6, 2023 4:11 AM, andy.shevchenko@xxxxxxxxx wrote: > > Fri, May 05, 2023 at 09:48:01PM +0300, andy.shevchenko@xxxxxxxxx kirjoitti: > > > Fri, May 05, 2023 at 03:42:21PM +0800, Jiawen Wu kirjoitti: ... > > > > + device_property_read_u32(&pdev->dev, "wx,i2c-snps-model", &dev->flags); > > > > > > I believe in your case it should be named something like > > > "linux,i2c-synopsys-platform". But in any case this I leave > > > to the more experienced people. > > > > Or "snps,i2c-platform", I dunno... > > I thought you wanted me to introduce a property specific to my device, > so I named it "wx,...". But the property meaning is not in this case. If you want the specific one, it should be boolean (it's also a possible way to go): if (device_property_present(...)) dev->flags |= MODEL_...; > But if it's a universal property for platform device, > maybe it's necessary to check if flag is NULL, otherwise the second result > will overwrite it. Right. With boolean like above it will be more robust. -- With Best Regards, Andy Shevchenko