> +static int psp_send_i2c_req_skyrim(enum psp_i2c_req_type i2c_req_type) > +{ > + return psp_ring_platform_doorbell(i2c_req_type); > +} Should this function retry acquiring the I2C bus while it is busy? Similar to how the cezanne variant works. Also wondering if the function should be named psp_send_i2c_req_mendocino for consistency. Sorry about the repost, the quoted code wasn't included originally.