> On Wed, Jan 12, 2022 at 3:14 PM Akhil R <akhilrajeev@xxxxxxxxxx> wrote: > > > > Get interrupt by name from ACPI table as well. > > > > Add option to use 'interrupt-names' in _DSD which can map to interrupt > > by index. The implementation is similar to 'interrupt-names' in devicetree. > > Also add a common routine to get irq by name from devicetree and ACPI > > table. > > > > Signed-off-by: Akhil R <akhilrajeev@xxxxxxxxxx> > > --- > > drivers/base/property.c | 35 +++++++++++++++++++++++++++++++++++ > > include/linux/property.h | 3 +++ > > 2 files changed, 38 insertions(+) > > > > diff --git a/drivers/base/property.c b/drivers/base/property.c index > > cbe4fa2..414c316 100644 > > --- a/drivers/base/property.c > > +++ b/drivers/base/property.c > > @@ -920,6 +920,41 @@ int fwnode_irq_get(const struct fwnode_handle > > *fwnode, unsigned int index) EXPORT_SYMBOL(fwnode_irq_get); > > > > /** > > + * fwnode_irq_get_byname - Get IRQ from a fwnode using its name > > + * @fwnode: Pointer to the firmware node > > + * @name: IRQ name in interrupt-names property in fwnode > > + * > > + * Returns Linux IRQ number on success, errno otherwise. > > + */ > > +int fwnode_irq_get_byname(const struct fwnode_handle *fwnode, const > > +char *name) { > > + int index; > > + > > + if (unlikely(!name)) > > + return -EINVAL; > > + > > + index = fwnode_property_match_string(fwnode, "interrupt-names", > name); > > + if (index < 0) > > + return index; > > + > > + return fwnode_irq_get(fwnode, index); } > > +EXPORT_SYMBOL(fwnode_irq_get_byname); > > + > > +/** > > + * device_irq_get_byname - Get IRQ of a device using interrupt name > > + * @dev: Device to get the interrupt > > + * @name: IRQ name in interrupt-names property in fwnode > > Which fwnode? > > > + * > > + * Returns Linux IRQ number on success, errno otherwise. > > + */ > > +int device_irq_get_byname(struct device *dev, const char *name) { > > + return fwnode_irq_get_byname(dev_fwnode(dev), name); } > > +EXPORT_SYMBOL_GPL(device_irq_get_byname); > > This can be confusing, because it pretends to be super-generic and in fact it > depends on an fwnode to be there. > > I guess I'd rather not have it at all, or use a more precise name for it. But, I suppose, the other device_*() functions also depend on the fwnode. Wouldn't it make the naming inconsistent if we add a different one here? Would it be better if I add more details in the description comment?