On Sat, 2021-10-02 at 08:30 +0200, Wolfram Sang wrote: > > +#define I2C_CLR_DEBUGCTR 0x0000 > > Hmm, I don't think that a macro to clear a register helps > readability... > > > + mtk_i2c_writew(i2c, I2C_CLR_DEBUGCTR, > > OFFSET_DEBUGCTRL); > > .. > > + mtk_i2c_writew(i2c, 0, OFFSET_DEBUGCTRL); > > looks good to me. Anyhow, it is not a big issue. Let me know if you > want > to change it or keep it. > OK, I will use 0x00 instead of macro on V8 version,Thanks.