Re: [PATCH] i2c: i801: Simplify initialization of i2c_board_info in i801_probe_optional_slaves

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 25 May 2021 22:01:31 +0200, Heiner Kallweit wrote:
> Why shall we bother to open-code something that the compiler can do for us.

I don't know, maybe it wasn't supported by older versions of gcc?

Surprisingly, this makes the binary a tad larger. I wonder why.

> Signed-off-by: Heiner Kallweit <hkallweit1@xxxxxxxxx>
> ---
>  drivers/i2c/busses/i2c-i801.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/i2c/busses/i2c-i801.c b/drivers/i2c/busses/i2c-i801.c
> index 9588d5bcf..0c08cfec5 100644
> --- a/drivers/i2c/busses/i2c-i801.c
> +++ b/drivers/i2c/busses/i2c-i801.c
> @@ -1291,11 +1291,11 @@ static void i801_probe_optional_slaves(struct i801_priv *priv)
>  		return;
>  
>  	if (apanel_addr) {
> -		struct i2c_board_info info;
> +		struct i2c_board_info info = {

Could be declared const now?

> +			.addr = apanel_addr,
> +			.type = "fujitsu_apanel"

We traditionally add a trailing comma on every line, so that adding a
line in the future will result in a smaller, more readable patch.

> +		};
>  
> -		memset(&info, 0, sizeof(struct i2c_board_info));
> -		info.addr = apanel_addr;
> -		strlcpy(info.type, "fujitsu_apanel", I2C_NAME_SIZE);
>  		i2c_new_client_device(&priv->adapter, &info);
>  	}
>  

Other than these minor details, no objection from me.

Reviewed-by: Jean Delvare <jdelvare@xxxxxxx>

-- 
Jean Delvare
SUSE L3 Support



[Index of Archives]     [Linux GPIO]     [Linux SPI]     [Linux Hardward Monitoring]     [LM Sensors]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux