06.09.2020 01:23, Michał Mirosław пишет: > On Sat, Sep 05, 2020 at 11:41:36PM +0300, Dmitry Osipenko wrote: >> The "dma" variable of tegra_i2c_xfer_msg() function doesn't bring much in >> regards to readability and generation of the code, hence let's remove it >> to clean up code a tad. > [...] >> --- a/drivers/i2c/busses/i2c-tegra.c >> +++ b/drivers/i2c/busses/i2c-tegra.c > [...] >> + if (i2c_dev->is_curr_dma_xfer) { > [...] > > In this case I like the previous code better: just because there are > less letters to read. :-) Besides readability, I also don't like much that the is_curr_dma_xfer is initialized in tegra_i2c_xfer_msg() and then could be overridden by tegra_i2c_config_fifo_trig(). In a result the "dma" variable confuses me since it's not instantly obvious why it's set after tegra_i2c_config_fifo_trig(). Looking at the final result, I think it's better to have the variable removed. It makes code more consistent, IMO.