Re: [PATCHv7 10/11] mfd: as3722: Rid driver of superfluous I2C device ID structure

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Thanks for your reviews again Javier,

On 07/11/16 19:20, Javier Martinez Canillas wrote:
> Hello Kieran,
> 
> On 11/07/2016 09:47 AM, Kieran Bingham wrote:
>> From: Lee Jones <lee.jones@xxxxxxxxxx>
>>
>> Also remove unused second probe() parameter 'i2c_device_id'.
>>
>> Acked-by: Grant Likely <grant.likely@xxxxxxxxxx>
>> Signed-off-by: Lee Jones <lee.jones@xxxxxxxxxx>
>> Signed-off-by: Kieran Bingham <kieran@xxxxxxxxxxx>
>>
>> ---
>> Changes since v4
>>  - Rename .probe2 to probe_new
>>
>>  drivers/mfd/as3722.c | 12 ++----------
>>  1 file changed, 2 insertions(+), 10 deletions(-)
>>
>> diff --git a/drivers/mfd/as3722.c b/drivers/mfd/as3722.c
>> index f87342c211bc..7d8c5e4136e2 100644
>> --- a/drivers/mfd/as3722.c
>> +++ b/drivers/mfd/as3722.c
>> @@ -354,8 +354,7 @@ static int as3722_i2c_of_probe(struct i2c_client *i2c,
>>  	return 0;
>>  }
>>  
>> -static int as3722_i2c_probe(struct i2c_client *i2c,
>> -			const struct i2c_device_id *id)
>> +static int as3722_i2c_probe(struct i2c_client *i2c)
>>  {
> 
> This is OK...
> 
>>  	struct as3722 *as3722;
>>  	unsigned long irq_flags;
>> @@ -441,12 +440,6 @@ static const struct of_device_id as3722_of_match[] = {
>>  };
>>  MODULE_DEVICE_TABLE(of, as3722_of_match);
>>  
>> -static const struct i2c_device_id as3722_i2c_id[] = {
>> -	{ "as3722", 0 },
>> -	{},
>> -};
>> -MODULE_DEVICE_TABLE(i2c, as3722_i2c_id);
>> -
> 
> ... but I don't think this is correct. Otherwise you will break module
> autoload for this driver since modpost needs the I2C device ID table
> info to fill the i2c modalias in the drivers' module.
> 
> Remember that i2c_device_uevent() always reports modalias of the form
> MODALIAS=i2c:<foo> even when your series allows to match without a I2C
> device ID table.
> 

Ok - Thanks for the reminder. I'll try to bear this in mind when we
start updating drivers.

For now we can consider this patch dropped from the series I think.

> Best regards,
> 

-- 
Regards

Kieran Bingham
--
To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux GPIO]     [Linux SPI]     [Linux Hardward Monitoring]     [LM Sensors]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux