On Wed, 29 Sep 2010 00:20:54 +0100, Ben Dooks wrote: > On Fri, Sep 24, 2010 at 04:14:53PM -0600, Grant Likely wrote: > > Commit 959e85f7, "i2c: add OF-style registration and binding" caused a > > module dependency loop where of_i2c.c calls functions in i2c-core, and > > i2c-core calls of_i2c_register_devices() in of_i2c. This means that > > when i2c support is built as a module when CONFIG_OF is set, then > > neither i2c_core nor of_i2c are able to be loaded. > > > > This patch fixes the problem by moving the of_i2c_register_devices() > > function into the body of i2c_core and renaming it to > > i2c_scan_of_devices (of_i2c_register_devices is analogous to the > > existing i2c_scan_static_board_info function and so should be named > > similarly). This function isn't called by any code outside of > > i2c_core, and it must always be present when CONFIG_OF is selected, so > > it makes sense to locate it there. When CONFIG_OF is not selected, > > of_i2c_register_devices() becomes a no-op. > > I sort of go with this one. Actually I would prefer option #2, even though I understand it won't make Grant too happy. Having a large chunk of OF-specific code in i2c-core, leaving of_i2c.c almost empty, doesn't seem right. I took a look at what other relevant subsystems do. SPI is boolean so it doesn't have the issue. MDIO is tristate, the registration function is in of_mdio.c and individual drivers call it. And there are a lot more of these (9) than i2c drivers (3). So I would let individual drivers call of_i2c_register_devices(), as it used to be until 2.6.35. 2 extra functions calls doesn't seem a high price to pay to keep the code logically separated. This also make things consistent, with all OF registration functions living under drivers/of. Thanks, -- Jean Delvare -- To unsubscribe from this list: send the line "unsubscribe linux-i2c" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html