On Sun, 27 Dec 2009 15:49:22 +0100, Roel Kluin wrote: > With `while (timeout++ < MAX_TIMEOUT)' timeout reaches MAX_TIMEOUT + 1 after the loop > This is probably unlikely to produce a problem. > > Signed-off-by: Roel Kluin <roel.kluin@xxxxxxxxx> > --- > drivers/i2c/busses/i2c-piix4.c | 2 +- > drivers/i2c/busses/i2c-viapro.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/i2c/busses/i2c-piix4.c b/drivers/i2c/busses/i2c-piix4.c > index 1e245e9..d8e0df0 100644 > --- a/drivers/i2c/busses/i2c-piix4.c > +++ b/drivers/i2c/busses/i2c-piix4.c > @@ -329,7 +329,7 @@ static int piix4_transaction(void) > msleep(1); > > /* If the SMBus is still busy, we give up */ > - if (timeout >= MAX_TIMEOUT) { > + if (timeout > MAX_TIMEOUT) { > dev_err(&piix4_adapter.dev, "SMBus Timeout!\n"); > result = -ETIMEDOUT; > } > diff --git a/drivers/i2c/busses/i2c-viapro.c b/drivers/i2c/busses/i2c-viapro.c > index e4b1543..8a2e0d5 100644 > --- a/drivers/i2c/busses/i2c-viapro.c > +++ b/drivers/i2c/busses/i2c-viapro.c > @@ -168,7 +168,7 @@ static int vt596_transaction(u8 size) > } while ((temp & 0x01) && (timeout++ < MAX_TIMEOUT)); > > /* If the SMBus is still busy, we give up */ > - if (timeout >= MAX_TIMEOUT) { > + if (timeout > MAX_TIMEOUT) { > result = -ETIMEDOUT; > dev_err(&vt596_adapter.dev, "SMBus timeout!\n"); > } That's right... but I'd rather change the loops to use "++timeout" and leave the conditions as is (or maybe change it to "=="). I think it's easier to read that way. Would that be OK with you? -- Jean Delvare -- To unsubscribe from this list: send the line "unsubscribe linux-i2c" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html