Re: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Sep 22, 2022 at 10:43:24PM +0000, Michael Kelley (LINUX) wrote:
> From: Michael Kelley (LINUX) <mikelley@xxxxxxxxxxxxx> Sent: Thursday, September 22, 2022 3:39 PM
> > 
> > From: Easwar Hariharan <eahariha@xxxxxxxxxxxxxxxxxxx> Sent: Monday, September
> > 19, 2022 3:05 PM
> > >
> > > pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
> > > linux/pci.h. Use the define instead of the magic number.
> > >
> > > Signed-off-by: Easwar Hariharan <easwar.hariharan@xxxxxxxxxxxxx>
> > > ---
> > >  drivers/hv/vmbus_drv.c | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> > > index 3c833ea..f2efb74 100644
> > > --- a/drivers/hv/vmbus_drv.c
> > > +++ b/drivers/hv/vmbus_drv.c
> > > @@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t
> > *type,
> > >  	child_device_obj->channel = channel;
> > >  	guid_copy(&child_device_obj->dev_type, type);
> > >  	guid_copy(&child_device_obj->dev_instance, instance);
> > > -	child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
> > > +	child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;
> > >
> > >  	return child_device_obj;
> > >  }
> > > --
> > > 1.8.3.1
> > 
> > Reviewed-by: Michael Kelley <mikelley@xxxxxxxxxxxxx>
> 
> Actually, a nit:  The short commit message should start with "Drivers: hv:" or
> "Drivers: hv: vmbus:".  Check the commit history on vmbus_drv.c and you'll
> see the standard usage.

I fixed up the commit message and applied it to hyperv-next. Thanks.

> 
> Michael
> 



[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]


  Powered by Linux