On Tue, Aug 27, 2024 at 03:04:42PM +0800, Shen Lichuan wrote: > Use the min() macro to simplify the pc87360_init_device() function > and improve its readability. > > Signed-off-by: Shen Lichuan <shenlichuan@xxxxxxxx> Applied. Thanks, Guenter > --- > drivers/hwmon/pc87360.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/hwmon/pc87360.c b/drivers/hwmon/pc87360.c > index 9e9681b2e8c5..788b5d58f77e 100644 > --- a/drivers/hwmon/pc87360.c > +++ b/drivers/hwmon/pc87360.c > @@ -1315,7 +1315,7 @@ static void pc87360_init_device(struct platform_device *pdev, > (reg & 0xC0) | 0x11); > } > > - nr = data->innr < 11 ? data->innr : 11; > + nr = min(data->innr, 11); > for (i = 0; i < nr; i++) { > reg = pc87360_read_value(data, LD_IN, i, > PC87365_REG_IN_STATUS);