On Wed, Aug 03, 2022 at 01:43:56PM -0400, Jack Champagne wrote: > The regmap_config variable for the ads7828 and the ads7830 are both > misnamed to `ads2828_regmap_config` and `ads2830_regmap_config` > respectively. These variables refer to regmap configs for the ads7828 > and the ads7830 and should be named accordingly. > > This patch does not introduce functional changes as the only two usages > of these regmap_config variables are within the changed file. > > Signed-off-by: Jack Champagne <jackchampagne.r@xxxxxxxxx> Please refrain from submitting patches with non-functional changes like this one unless you are also submitting patches with functional changes. Guenter > --- > drivers/hwmon/ads7828.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/hwmon/ads7828.c b/drivers/hwmon/ads7828.c > index 7246198f0901..20bdee769882 100644 > --- a/drivers/hwmon/ads7828.c > +++ b/drivers/hwmon/ads7828.c > @@ -89,12 +89,12 @@ static struct attribute *ads7828_attrs[] = { > > ATTRIBUTE_GROUPS(ads7828); > > -static const struct regmap_config ads2828_regmap_config = { > +static const struct regmap_config ads7828_regmap_config = { > .reg_bits = 8, > .val_bits = 16, > }; > > -static const struct regmap_config ads2830_regmap_config = { > +static const struct regmap_config ads7830_regmap_config = { > .reg_bits = 8, > .val_bits = 8, > }; > @@ -152,11 +152,11 @@ static int ads7828_probe(struct i2c_client *client) > if (chip == ads7828) { > data->lsb_resol = DIV_ROUND_CLOSEST(vref_mv * 1000, 4096); > data->regmap = devm_regmap_init_i2c(client, > - &ads2828_regmap_config); > + &ads7828_regmap_config); > } else { > data->lsb_resol = DIV_ROUND_CLOSEST(vref_mv * 1000, 256); > data->regmap = devm_regmap_init_i2c(client, > - &ads2830_regmap_config); > + &ads7830_regmap_config); > } > > if (IS_ERR(data->regmap)) > -- > 2.25.1 >