On 17/05/2022 09:57, Holger Brunck wrote: > Some devices can operate in an extended temperature mode. > Therefore add a boolean ti,extended-range-enable to be able to > select this feature in the device tree node. Also make sure that this > feature can only be enabled for the devices supporting this feature. > > Signed-off-by: Holger Brunck <holger.brunck@xxxxxxxxxxxxxxxxx> > --- > changes for v3: > - rename property to ti,extended-range-enable > - use allOf:if to check if the device supports this feature > - rephrase commit msg Please use standard email subjects, so with the PATCH keyword in the title. `git format-patch` helps here to create proper versioned patch. Skipping it makes filtering of emails more difficult thus making the review process less convenient. Then use standard email-sending tools to properly thread your patchset. git send-email for example. Kernel docs also explain this. Currently, this patchset is not possible to apply due to missing threading. > > .../bindings/hwmon/national,lm90.yaml | 18 ++++++++++++++++++ > 1 file changed, 18 insertions(+) > > diff --git a/Documentation/devicetree/bindings/hwmon/national,lm90.yaml b/Documentation/devicetree/bindings/hwmon/national,lm90.yaml > index 48b7065798b0..1c39b1b4011b 100644 > --- a/Documentation/devicetree/bindings/hwmon/national,lm90.yaml > +++ b/Documentation/devicetree/bindings/hwmon/national,lm90.yaml > @@ -53,10 +53,28 @@ properties: > vcc-supply: > description: phandle to the regulator that provides the +VCC supply > > + ti,extended-range-enable: > + description: Set to enable extended range temperature. > + type: boolean > + > required: > - compatible > - reg > > +allOf: > + - if: not: and then skip else > + properties: > + compatible: > + contains: > + enum: > + - adi,adt7461 > + - adi,adt7461a > + - ti,tmp451 > + - ti,tmp461 > + else: > + properties: > + ti,extended-range-enable: false > + > additionalProperties: false > > examples: Best regards, Krzysztof