Re: [PATCH v4 2/2] hwmon: intel-m10-bmc-hwmon: use devm_hwmon_sanitize_name()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 4/5/22 2:24 AM, Michael Walle wrote:
Instead of open-coding the bad characters replacement in the hwmon name,
use the new devm_hwmon_sanitize_name().

Signed-off-by: Michael Walle <michael@xxxxxxxx>
Acked-by: Xu Yilun <yilun.xu@xxxxxxxxx>
---
  drivers/hwmon/intel-m10-bmc-hwmon.c | 11 +++--------
  1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/drivers/hwmon/intel-m10-bmc-hwmon.c b/drivers/hwmon/intel-m10-bmc-hwmon.c
index 7a08e4c44a4b..6e82f7200d1c 100644
--- a/drivers/hwmon/intel-m10-bmc-hwmon.c
+++ b/drivers/hwmon/intel-m10-bmc-hwmon.c
@@ -515,7 +515,6 @@ static int m10bmc_hwmon_probe(struct platform_device *pdev)
  	struct intel_m10bmc *m10bmc = dev_get_drvdata(pdev->dev.parent);
  	struct device *hwmon_dev, *dev = &pdev->dev;
  	struct m10bmc_hwmon *hw;
-	int i;
hw = devm_kzalloc(dev, sizeof(*hw), GFP_KERNEL);
  	if (!hw)
@@ -528,13 +527,9 @@ static int m10bmc_hwmon_probe(struct platform_device *pdev)
  	hw->chip.info = hw->bdata->hinfo;
  	hw->chip.ops = &m10bmc_hwmon_ops;
- hw->hw_name = devm_kstrdup(dev, id->name, GFP_KERNEL);
-	if (!hw->hw_name)
-		return -ENOMEM;
-
-	for (i = 0; hw->hw_name[i]; i++)
-		if (hwmon_is_bad_char(hw->hw_name[i]))
-			hw->hw_name[i] = '_';
+	hw->hw_name = devm_hwmon_sanitize_name(dev, id->name);
+	if (IS_ERR(hw->hw_name))
+		return PTR_ERR(hw->hw_name);
Reviewed-by: Tom Rix <trix@xxxxxxxxxx>
hwmon_dev = devm_hwmon_device_register_with_info(dev, hw->hw_name,
  							 hw, &hw->chip, NULL);




[Index of Archives]     [LM Sensors]     [Linux Sound]     [ALSA Users]     [ALSA Devel]     [Linux Audio Users]     [Linux Media]     [Kernel]     [Gimp]     [Yosemite News]     [Linux Media]

  Powered by Linux