Re: [PATCH] net: phy: tja11xx: Switch to HWMON_CHANNEL_INFO()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, May 28, 2019 at 08:15:41PM +0200, Marek Vasut wrote:
> The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
> of errors, and makes the code easier to read.
> 
> Signed-off-by: Marek Vasut <marex@xxxxxxx>
> Cc: Andrew Lunn <andrew@xxxxxxx>
> Cc: Florian Fainelli <f.fainelli@xxxxxxxxx>
> Cc: Guenter Roeck <linux@xxxxxxxxxxxx>

Reviewed-by: Guenter Roeck <linux@xxxxxxxxxxxx>

> Cc: Heiner Kallweit <hkallweit1@xxxxxxxxx>
> Cc: Jean Delvare <jdelvare@xxxxxxxx>
> Cc: linux-hwmon@xxxxxxxxxxxxxxx
> ---
>  drivers/net/phy/nxp-tja11xx.c | 24 ++----------------------
>  1 file changed, 2 insertions(+), 22 deletions(-)
> 
> diff --git a/drivers/net/phy/nxp-tja11xx.c b/drivers/net/phy/nxp-tja11xx.c
> index 11b8701e78fd..b705d0bd798b 100644
> --- a/drivers/net/phy/nxp-tja11xx.c
> +++ b/drivers/net/phy/nxp-tja11xx.c
> @@ -311,29 +311,9 @@ static umode_t tja11xx_hwmon_is_visible(const void *data,
>  	return 0;
>  }
>  
> -static u32 tja11xx_hwmon_in_config[] = {
> -	HWMON_I_LCRIT_ALARM,
> -	0
> -};
> -
> -static const struct hwmon_channel_info tja11xx_hwmon_in = {
> -	.type		= hwmon_in,
> -	.config		= tja11xx_hwmon_in_config,
> -};
> -
> -static u32 tja11xx_hwmon_temp_config[] = {
> -	HWMON_T_CRIT_ALARM,
> -	0
> -};
> -
> -static const struct hwmon_channel_info tja11xx_hwmon_temp = {
> -	.type		= hwmon_temp,
> -	.config		= tja11xx_hwmon_temp_config,
> -};
> -
>  static const struct hwmon_channel_info *tja11xx_hwmon_info[] = {
> -	&tja11xx_hwmon_in,
> -	&tja11xx_hwmon_temp,
> +	HWMON_CHANNEL_INFO(in, HWMON_I_LCRIT_ALARM),
> +	HWMON_CHANNEL_INFO(temp, HWMON_T_CRIT_ALARM),
>  	NULL
>  };
>  
> -- 
> 2.20.1
> 



[Index of Archives]     [LM Sensors]     [Linux Sound]     [ALSA Users]     [ALSA Devel]     [Linux Audio Users]     [Linux Media]     [Kernel]     [Gimp]     [Yosemite News]     [Linux Media]

  Powered by Linux