Hi Geert, Thank you for the review. On Wed, May 22, 2024 at 1:44 PM Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> wrote: > > Hi Prabhakar, > > On Tue, Apr 23, 2024 at 7:59 PM Prabhakar <prabhakar.csengg@xxxxxxxxx> wrote: > > From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx> > > > > This patch introduces function pointers, read_oen() and write_oen(), in the > > struct rzg2l_pinctrl_data to facilitate reading and writing to the PFC_OEN > > register. On the RZ/V2H(P) SoC, unlocking the PWPR.REGWE_B bit before > > writing to the PFC_OEN register is necessary, and the PFC_OEN register has > > more bits compared to the RZ/G2L family. To handle these differences > > between RZ/G2L and RZ/V2H(P) and to reuse the existing code for RZ/V2H(P), > > these function pointers are introduced. > > > > Additionally, this patch populates these function pointers with appropriate > > data for existing SoCs. > > > > Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx> > > --- > > RFC->v2 > > - No change > > Thanks for the update! > > > --- a/drivers/pinctrl/renesas/pinctrl-rzg2l.c > > +++ b/drivers/pinctrl/renesas/pinctrl-rzg2l.c > > @@ -261,6 +261,8 @@ struct rzg2l_pinctrl_data { > > void (*pwpr_pfc_unlock)(struct rzg2l_pinctrl *pctrl); > > void (*pwpr_pfc_lock)(struct rzg2l_pinctrl *pctrl); > > void (*pmc_writeb)(struct rzg2l_pinctrl *pctrl, u8 val, void __iomem *addr); > > + u32 (*read_oen)(struct rzg2l_pinctrl *pctrl, u32 caps, u32 offset, u8 pin); > > + int (*write_oen)(struct rzg2l_pinctrl *pctrl, u32 caps, u32 offset, u8 pin, u8 oen); > > Please use consistent naming: "pmc_writeb" uses <noun>_<verb> ordering, > "read_oen" uses <verb>_<noun> ordering. > Ok, I'll rename them to oen_read() and oen_write(). Cheers, Prabhakar