From: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx> Here's an assortment of improvements to parsing and handling of timeouts in gpio-tools. I still decided to unify the period parsing between gpioset and gpioget even if it doesn't make much sense for gpioget to support periods longer than fractions of a second. Let users decide. v1 -> v2: - extend the series with renaming the timeout variable, using ppoll() instead of poll() and supporting minutes as time unit - drop already applied patch Bartosz Golaszewski (4): tools: rename timeout to idle_timeout in gpiomon and gpionotify tools: use ppoll() where higher timeout resolution makes sense tools: allow longer time periods tools: add minutes as a new supported time unit configure.ac | 2 ++ tools/gpioget.c | 4 ++-- tools/gpiomon.c | 28 +++++++++++++++++++++------- tools/gpionotify.c | 16 ++++++++++++---- tools/gpioset.c | 16 ++++++++-------- tools/tools-common.c | 32 ++++++++++++++++++++++---------- tools/tools-common.h | 5 +++-- 7 files changed, 70 insertions(+), 33 deletions(-) -- 2.40.1