On Fri, Dec 15, 2023 at 2:04 AM Kent Gibson <warthog618@xxxxxxxxx> wrote: > > On Thu, Dec 14, 2023 at 10:06:14PM +0100, Bartosz Golaszewski wrote: > > On Thu, Dec 14, 2023 at 5:41 PM Andy Shevchenko <andy@xxxxxxxxxx> wrote: > > > > > > On Fri, Dec 15, 2023 at 12:14:41AM +0800, Kent Gibson wrote: > > > > On Thu, Dec 14, 2023 at 05:09:01PM +0200, Andy Shevchenko wrote: > > > > > On Thu, Dec 14, 2023 at 05:03:03PM +0200, Andy Shevchenko wrote: > > > > > > On Thu, Dec 14, 2023 at 05:58:11PM +0800, Kent Gibson wrote: > > > > > > ... > > > > > > > > > > +static void supinfo_init(void) > > > > > > > +{ > > > > > > > + supinfo.tree = RB_ROOT; > > > > > > > + spin_lock_init(&supinfo.lock); > > > > > > > +} > > > > > > > > > > > > Can it be done statically? > > > > > > > > > > > > supinfo = { > > > > > > .tree = RB_ROOT, > > > > > > .lock = __SPIN_LOCK_UNLOCKED(supinfo.lock), > > > > Double underscore typically means it's private and shouldn't be used. > > > > You mean like __assign_bit(), __set_bit(), __clear_bit() and __free() - > all used in gpiolib.c? > Touché. But this is just lack of strict naming conventions. :( Another common use of leading underscores are "unlocked" (or in this case: non-atomic) variants of functions. > > > > > > > > > > I even checked the current tree, we have 32 users of this pattern in drivers/. > > > > As opposed to ~1200 uses of DEFINE_SPINLOCK if you really want to go there. :) > > > > Ah, that is what you meant. Yeah sure can - the supinfo_init() is > > > > another hangover from when I was trying to create the supinfo per chip, > > > > but now it is a global a static initialiser makes sense. > > > > > > Yep, the DEFINE_MUTEX() / DEFINE_SPINLOCK() / etc looks better naturally > > > than above. > > > > Yeah, so maybe we should use non-struct, global variables after all. > > > > Despite the 32 cases cited that already use that pattern? > 9 of which use __SPIN_LOCK_UNLOCKED(). > Sounds like a pretty convincing argument to use the struct ;-). > > But lets keep it as kosher as possible and split out the struct :-(. > I'll leave it for you to decide, I don't have a strong opinion and the entire file is your code so you should pick. Bart > Cheers, > Kent. >