On Wed, Dec 13, 2023 at 11:11:34PM +0800, Kent Gibson wrote: > On Wed, Dec 13, 2023 at 10:07:28PM +0800, Kent Gibson wrote: > > On Wed, Dec 13, 2023 at 03:56:27PM +0200, Andy Shevchenko wrote: > > > On Tue, Dec 12, 2023 at 01:42:52PM +0800, Kent Gibson wrote: ... > > > > - unsigned long flags; > > > > + unsigned long iflags, dflags; > > > > > > With a preliminary conversion to cleanup.h this whole change becomes cleaner, > > > no? > > > > You mean the scoped guards? Dunno - haven't used them. > > Care to provide more detail? > > Ok, so changing the spin_lock/unlock to > > scoped_guard(spinlock_irqsave, &gpio_lock) { > ... > } > > you no longer need the iflags at all, and can rename dflags to flags. Yes, but I prefer still dflags as it is a distinction from the lock flags and we use lflags/dflags a lot in GPIO library, so reading the code will give a hint about the semantics. > Got it. -- With Best Regards, Andy Shevchenko