On Mon, Oct 2, 2023 at 11:46 AM Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > On Wed, Sep 27, 2023 at 04:29:25PM +0200, Bartosz Golaszewski wrote: > > From: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx> > > > > Getting the GPIO descriptor directly from the gpio_chip struct is > > dangerous as we don't take the reference to the underlying GPIO device. > > In order to start working towards removing gpiochip_get_desc(), let's > > provide a safer variant that works with an existing reference to struct > > gpio_device. > > ... > > > +EXPORT_SYMBOL_GPL(gpiochip_get_desc); > > > +struct gpio_desc * > > +gpio_device_get_desc(struct gpio_device *gdev, unsigned int hwnum) > > I'm wondering if you move this to be upper than gpiochip_get_desc() and > diff will look better... > There's a limit to bikeshedding in my book and "making the diff look better" is definitely it. :) Bart