On Tue, Sep 19, 2023 at 12:31:36AM -0700, brgl@xxxxxxxx wrote: > On Mon, 18 Sep 2023 17:31:36 +0200, Andy Shevchenko > <andriy.shevchenko@xxxxxxxxxxxxxxx> said: > > On Mon, Sep 18, 2023 at 04:55:33PM +0200, Bartosz Golaszewski wrote: > >> From: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx> > >> > >> gpio_sim_make_line_names() returns NULL or ERR_PTR() so we must not use > >> __free(kfree) on the returned address. Split this function into two, one > >> that determines the size of the "gpio-line-names" array to allocate and > >> one that actually sets the names at correct offsets. The allocation and > >> assignment of the managed pointer happens in between. > > > > ... > > > >> + unsigned int size = 0; > >> > >> list_for_each_entry(line, &bank->line_list, siblings) { > >> + if (!line->name || (line->offset >= bank->num_lines)) > >> continue; > >> > >> + size = line->offset + 1; > >> } > >> > >> + return size; > > > > So, now the function iterates over all lines and returns the size of the last > > match, correct? > > > > Why not > > > > list_for_each_entry_reversed() { > > if (line->name && ()) > > break; > > } > > > > return size; > > > > ? > > Because the line objects are not sorted by offset. They are added at the end > of the list in the order the user creates their corresponding configfs groups. > Then your patch is also broken as it uses the last named entry, not the named entry with the greatest offset?? Cheers, Kent.