On Thu, Aug 17, 2023 at 08:49:54PM +0200, Bartosz Golaszewski wrote: > From: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx> > > This function is a wrapper around container_of(). It's used only once and > we will have a second notifier soon, so instead of having two flavors of > this helper, let's just open-code where needed. ... > + struct gpio_chardev_data *cdev = container_of(nb, > + struct gpio_chardev_data, > + lineinfo_changed_nb); This way it's slightly better. struct gpio_chardev_data *cdev = container_of(nb, struct gpio_chardev_data, lineinfo_changed_nb); -- With Best Regards, Andy Shevchenko