On Mon, Jan 16, 2023 at 7:02 AM Viresh Kumar <viresh.kumar@xxxxxxxxxx> wrote: > > On 13-01-23, 22:52, Bartosz Golaszewski wrote: > > diff --git a/bindings/rust/libgpiod/tests/line_request.rs b/bindings/rust/libgpiod/tests/line_request.rs > > index c3fc37b..561f4e8 100644 > > --- a/bindings/rust/libgpiod/tests/line_request.rs > > +++ b/bindings/rust/libgpiod/tests/line_request.rs > > @@ -97,13 +97,11 @@ mod line_request { > > config.lconfig_add_settings(&offsets); > > config.request_lines().unwrap(); > > > > - let request = config.request(); > > - > > Why remove this ? And open-code it ? > Because I'm a Rust noob and couldn't figure out how to deal with the mutable/non-mutable borrow vomit that ensued when I kept the local variable. If you could improve upon this one, it would be great! Bart