On Wed, Jul 20, 2022 at 3:46 PM William Breathitt Gray <william.gray@xxxxxxxxxx> wrote: > > Rebased onto the gpio/for-next branch. > > Changes in v4: > - Cleanup superfluous header includes from drivers > - Add note to CONFIG_GPIO_I8255 Kconfig that if built as a module the > name will be 'gpio-i8255' > - Remove 'const' from '__iomem' pointers > - Replace ambiguous 'group' terminology with more understandable 'bank' > - Use more natural '>= 4' expression to represent upper nibble > - Refactor i8255_set_port() to take more common pattern of mask and > bits > > The PC104/ISA drivers were updated to use I/O memory accessor calls such > as ioread8()/iowrite8() in a previous patch series [0]. This > patchset is a continuation of the effort to improve the code readability > and reduce magic numbers by implementing and utilizing named register > data structures. > > One of the benefits is that we can now observe more easily similarities > in devices that share similar interfaces; such as the i8255 interfaces > used by the 104-DIO-48E, 104-IDI-48, and GPIO-MM drivers -- as well as > the similar interface used by the 104-IDIO-16 and PCI-IDIO-16 drivers. > > A new module supporting the Intel 8255 interface is introduced to > consolidate the common code found among the 104-DIO-48E, 104-IDI-48, and > GPIO-MM drivers. > > [0] https://lore.kernel.org/all/cover.1652201921.git.william.gray@xxxxxxxxxx/ > Series applied, thanks! Bart