On Fri, Apr 29, 2022 at 8:28 PM Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > Hi Linux GPIO maintainers, > > Supposed to be an immutable tag to be included in GPIO and pin control subsystems. > Have been in Linux Next for a while w.o. any issues reported. Please, pull. > > Thanks, > > With Best Regards, > Andy Shevchenko > > The following changes since commit 0c2cae09a765b1c1d842eb9328982976ec735926: > > gpiolib: acpi: Convert type for pin to be unsigned (2022-04-08 15:13:22 +0300) > > are available in the Git repository at: > > git://git.kernel.org/pub/scm/linux/kernel/git/andy/linux-gpio-intel.git tags/intel-gpio-v5.19-1 > > for you to fetch changes up to edc5601db66411a8c9c6b08b3aacf7e154a34c6d: > > pinctrl: meson: Replace custom code by gpiochip_node_count() call (2022-04-18 16:18:52 +0300) > > ---------------------------------------------------------------- > intel-gpio for v5.19-1 > > * Introduce helpers to iterate over GPIO chip nodes and covert some drivers > > The following is an automated git shortlog grouped by driver: > > gpiolib: > - Introduce a helper to get first GPIO controller node > - Introduce gpiochip_node_count() helper > - Introduce for_each_gpiochip_node() loop helper > > pinctrl: > - meson: Replace custom code by gpiochip_node_count() call > - meson: Enable COMPILE_TEST > - meson: Rename REG_* to MESON_REG_* > - armada-37xx: Reuse GPIO fwnode in armada_37xx_irqchip_register() > - armada-37xx: Switch to use fwnode instead of of_node > - samsung: Switch to use for_each_gpiochip_node() helper > - samsung: Drop redundant node parameter in samsung_banks_of_node_get() > - npcm7xx: Switch to use for_each_gpiochip_node() helper > - renesas: rza1: Switch to use for_each_gpiochip_node() helper > - renesas: rza1: Replace custom code by gpiochip_node_count() call > - stm32: Switch to use for_each_gpiochip_node() helper > - stm32: Replace custom code by gpiochip_node_count() call > > ---------------------------------------------------------------- > Andy Shevchenko (15): > gpiolib: Introduce for_each_gpiochip_node() loop helper > gpiolib: Introduce gpiochip_node_count() helper > pinctrl: stm32: Replace custom code by gpiochip_node_count() call > pinctrl: stm32: Switch to use for_each_gpiochip_node() helper > pinctrl: renesas: rza1: Replace custom code by gpiochip_node_count() call > pinctrl: renesas: rza1: Switch to use for_each_gpiochip_node() helper > pinctrl: npcm7xx: Switch to use for_each_gpiochip_node() helper > pinctrl: samsung: Drop redundant node parameter in samsung_banks_of_node_get() > pinctrl: samsung: Switch to use for_each_gpiochip_node() helper > gpiolib: Introduce a helper to get first GPIO controller node > pinctrl: armada-37xx: Switch to use fwnode instead of of_node > pinctrl: armada-37xx: Reuse GPIO fwnode in armada_37xx_irqchip_register() > pinctrl: meson: Rename REG_* to MESON_REG_* > pinctrl: meson: Enable COMPILE_TEST > pinctrl: meson: Replace custom code by gpiochip_node_count() call > > drivers/pinctrl/meson/Kconfig | 2 +- > drivers/pinctrl/meson/pinctrl-meson.c | 52 +++++----- > drivers/pinctrl/meson/pinctrl-meson.h | 28 +++--- > drivers/pinctrl/mvebu/pinctrl-armada-37xx.c | 34 ++----- > drivers/pinctrl/nuvoton/pinctrl-npcm7xx.c | 142 ++++++++++++---------------- > drivers/pinctrl/renesas/pinctrl-rza1.c | 47 +++------ > drivers/pinctrl/samsung/pinctrl-exynos.c | 8 +- > drivers/pinctrl/samsung/pinctrl-s3c24xx.c | 2 +- > drivers/pinctrl/samsung/pinctrl-s3c64xx.c | 4 +- > drivers/pinctrl/samsung/pinctrl-samsung.c | 30 +++--- > drivers/pinctrl/samsung/pinctrl-samsung.h | 2 +- > drivers/pinctrl/stm32/pinctrl-stm32.c | 80 +++++++--------- > include/linux/gpio/driver.h | 28 +++++- > 13 files changed, 210 insertions(+), 249 deletions(-) > > -- > With Best Regards, > Andy Shevchenko > > Pulled, thanks! Bart