Re: [PATCH v5 3/5] pinctrl: qcom: Extract chip specific LPASS LPI code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 12/8/2021 11:58 AM, Andy Shevchenko wrote:
Thanks for your time Andy!!!
On Wed, Dec 8, 2021 at 2:39 AM Srinivasa Rao Mandadapu
<quic_srivasam@xxxxxxxxxxx> wrote:
Extract the chip specific SM8250 data from the LPASS LPI pinctrl driver
to allow reusing the common code in the addition of subsequent
platforms.
...

@@ -661,8 +454,10 @@ static int lpi_pinctrl_probe(struct platform_device *pdev)

         return ret;
  }
+EXPORT_SYMBOL(lpi_pinctrl_probe);
+
Stray change.

...

okay. will remove it.


+#ifndef __PINCTRL_LPASS_LPI_H__
+#define __PINCTRL_LPASS_LPI_H__
Missed headers.
At least bits.h.

...
Okay. will add.
+#define NO_SLEW                                -1
Naming sucks for the header.

LPI_NO_SLEW ?

Actually it's already mainline code. Just these patches are rearrangement of old code.

still do you suggest to change?


...

+struct lpi_pingroup {
+       const char *name;
+       const unsigned int *pins;
+       unsigned int npins;
+       unsigned int pin;
+       /* Bit offset in slew register for SoundWire pins only */
+       int slew_offset;
+       unsigned int *funcs;
+       unsigned int nfuncs;
+};
Are you going to convert this to use struct group_desc?

...

+       LPI_MUX__,
Strange naming. Besides, if it is the terminator, drop the comma.
okay will remove comma. but name is from existing code.




[Index of Archives]     [Linux SPI]     [Linux Kernel]     [Linux ARM (vger)]     [Linux ARM MSM]     [Linux Omap]     [Linux Arm]     [Linux Tegra]     [Fedora ARM]     [Linux for Samsung SOC]     [eCos]     [Linux Fastboot]     [Gcc Help]     [Git]     [DCCP]     [IETF Announce]     [Security]     [Linux MIPS]     [Yosemite Campsites]

  Powered by Linux