On Wed, Aug 11, 2021 at 02:50:46PM +0200, Linus Walleij wrote: > On Wed, Aug 4, 2021 at 6:15 PM Andy Shevchenko > <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > > For backward compatibility with some legacy devices introduce > > a new (*) property gpio-base to read GPIO base. This will allow > > further cleaning up of the driver. > > > > *) Note, it's not new for the GPIO library since the mockup driver > > is using it already. > > > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > > --- > > v2: added check to ensure that the property won't be used by FW (Serge) > > drivers/gpio/gpio-dwapb.c | 4 ++++ > > 1 file changed, 4 insertions(+) > > > > diff --git a/drivers/gpio/gpio-dwapb.c b/drivers/gpio/gpio-dwapb.c > > index 4c7153cb646c..674e91e69cc5 100644 > > --- a/drivers/gpio/gpio-dwapb.c > > +++ b/drivers/gpio/gpio-dwapb.c > > @@ -584,6 +584,10 @@ static struct dwapb_platform_data *dwapb_gpio_get_pdata(struct device *dev) > > > > pp->gpio_base = -1; > > > > + /* For internal use only, new platforms mustn't exercise this */ > > + if (is_software_node(fwnode)) > > + fwnode_property_read_u32(fwnode, "gpio-base", &pp->gpio_base); > > You rewrite the code quicker than I can review :D Sorry for that :-) > So this is elegant, I would prefer "linux,gpio-base" but the > overall change is more important, with or without that change: I'm okay with the either, but the thing is that gpio-base is already in use. Perhaps in the future somebody can change both (gpio-mockup and this driver) to use the proposed one (AFAIU we free to change it since it's not part of FW interface). > Reviewed-by: Linus Walleij <linus.walleij@xxxxxxxxxx> Thanks! -- With Best Regards, Andy Shevchenko