Michael Walle <michael@xxxxxxxx> writes: > Am 2021-05-21 08:28, schrieb Matti Vaittinen: >> Slightly simplify the devm_gpio_regmap_register() by using the >> devm_add_action(). > > Hm, nice, but what bothers me a bit is that no other subsystem > does it that way, eg. hwmon/hwmon.c or watchdog/watchdog_core.c. > They also store just one pointer, thus could be simplified in the > same way. What I don't know is if devm_add_action() was intended > to be used this way. So I can't say much for this patch ;) There are some examples. Like: int devm_i2c_add_adapter(struct device *dev, struct i2c_adapter *adapter) { int ret; ret = i2c_add_adapter(adapter); if (ret) return ret; return devm_add_action_or_reset(dev, devm_i2c_del_adapter, adapter); } You should probably use the devm_add_action_or_reset() wrapper here too, catching the unlikely devm_add_action() alloc failure. Bjørn