On Thu, May 20, 2021 at 12:16:20PM +0300, Andy Shevchenko wrote: > On Thu, May 20, 2021 at 10:33:38AM +0200, Johan Hovold wrote: > > On Thu, May 20, 2021 at 11:15:31AM +0300, Andy Shevchenko wrote: > > > On Thu, May 20, 2021 at 11:07 AM Johan Hovold <johan@xxxxxxxxxx> wrote: > > > > On Tue, May 18, 2021 at 11:33:39AM +0300, Andy Shevchenko wrote: > > > > > > The _if suffix here is too vague. > > > > > > > > Please use a more descriptive name so that you don't need to look at the > > > > implementation to understand what the macro does. > > > > > > > > Perhaps call it > > > > > > > > for_each_gpio_desc_with_flag() > > > > or just add the more generic macro > > > > > > > > for_each_gpio_desc() > > > > > > > > and open-code the test so that it's clear what's going on here. > > > > FWIW, NAK due to the non-descriptive for_each_desc_if() name. > > Btw, missed argument > > ..._with_flag(..., FLAG_...) > > breaks the DRY principle. If you read current code it's clear with that > > _if(..., FLAG_...) That we have precisely zero for_each_ macros with an _if suffix should also give you a hint that this is not a good idea. Again, you shouldn't have to look at the implementation to understand what a helper does. Johan