On 4/8/21 4:55 PM, Andy Shevchenko wrote: > Kernel doc validator complains: > > .../gpio-xilinx.c:556: warning: expecting prototype for xgpio_of_probe(). Prototype was for xgpio_probe() instead > > Correct as suggested by changing the name of the function in the doc.. > > Fixes: 749564ffd52d ("gpio/xilinx: Convert the driver to platform device interface") > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > --- > drivers/gpio/gpio-xilinx.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpio/gpio-xilinx.c b/drivers/gpio/gpio-xilinx.c > index b411d3156e0b..136557e7dd3c 100644 > --- a/drivers/gpio/gpio-xilinx.c > +++ b/drivers/gpio/gpio-xilinx.c > @@ -542,7 +542,7 @@ static void xgpio_irqhandler(struct irq_desc *desc) > } > > /** > - * xgpio_of_probe - Probe method for the GPIO device. > + * xgpio_probe - Probe method for the GPIO device. > * @pdev: pointer to the platform device > * > * Return: > Reviewed-by: Michal Simek <michal.simek@xxxxxxxxxx> Thanks, Michal