On Tue, Feb 9, 2021 at 3:31 PM Nikita Shubin <nikita.shubin@xxxxxxxxxxx> wrote: ... > + .irq = _irq, \ > .has_irq = _has_irq, \ > .has_hierarchical_irq = _has_hier, \ Just a side note for the further cleanup. No need to resend or update right now! (of course if you or maintainers feel otherwise...) Now you have the duplicate information, i.e. irq covers has_irq. Hence you may drop has_irq, rename has_hierarchival_irq to is_irq_hierarchical and update below table. > static struct ep93xx_gpio_bank ep93xx_gpio_banks[] = { > /* Bank A has 8 IRQs */ > - EP93XX_GPIO_BANK("A", 0x00, 0x10, 0, true, false, 64), > + EP93XX_GPIO_BANK("A", 0x00, 0x10, 0x90, 0, true, false, 64), > /* Bank B has 8 IRQs */ > - EP93XX_GPIO_BANK("B", 0x04, 0x14, 8, true, false, 72), > - EP93XX_GPIO_BANK("C", 0x08, 0x18, 40, false, false, 0), > - EP93XX_GPIO_BANK("D", 0x0c, 0x1c, 24, false, false, 0), > - EP93XX_GPIO_BANK("E", 0x20, 0x24, 32, false, false, 0), > + EP93XX_GPIO_BANK("B", 0x04, 0x14, 0xac, 8, true, false, 72), > + EP93XX_GPIO_BANK("C", 0x08, 0x18, 0x00, 40, false, false, 0), > + EP93XX_GPIO_BANK("D", 0x0c, 0x1c, 0x00, 24, false, false, 0), > + EP93XX_GPIO_BANK("E", 0x20, 0x24, 0x00, 32, false, false, 0), > /* Bank F has 8 IRQs */ > - EP93XX_GPIO_BANK("F", 0x30, 0x34, 16, false, true, 0), > - EP93XX_GPIO_BANK("G", 0x38, 0x3c, 48, false, false, 0), > - EP93XX_GPIO_BANK("H", 0x40, 0x44, 56, false, false, 0), > + EP93XX_GPIO_BANK("F", 0x30, 0x34, 0x4c, 16, false, true, 0), > + EP93XX_GPIO_BANK("G", 0x38, 0x3c, 0x00, 48, false, false, 0), > + EP93XX_GPIO_BANK("H", 0x40, 0x44, 0x00, 56, false, false, 0), > }; -- With Best Regards, Andy Shevchenko