There are two fixes (and several cleanups) that allow to take into consideration more parameters in ACPI, i.e. bias for GpioInt() and debounce time for Operation Regions, Events and GpioInt() resources. The first patch highly depends on Intel pin control driver changes (they are material for v5.10 [1]), so this is probably not supposed to be backported (at least right now). The last patch adds Intel GPIO tree as official one for ACPI GPIO changes. Assuming [1] makes v5.10 this series can be sent as PR to Linus for v5.11 cycle. Cc: Jamie McClymont <jamie@xxxxxxxxxx> Cc: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx> Cc: Hans de Goede <hdegoede@xxxxxxxxxx> [1]: https://lore.kernel.org/linux-gpio/20201106181938.GA41213@xxxxxxxxxxxxxxxxxx/ Changelog v4: - extended debounce setting to ACPI events and Operation Regions - added Ack (Linus) - added few more cleanup patches, including MAINTAINERS update Changelog v3: - dropped upstreamed OF patch - added debounce fix Andy Shevchenko (9): gpiolib: acpi: Respect bias settings for GpioInt() resource gpiolib: acpi: Use named item for enum gpiod_flags variable gpiolib: acpi: Take into account debounce settings gpiolib: acpi: Move acpi_gpio_to_gpiod_flags() upper in the code gpiolib: acpi: Make acpi_gpio_to_gpiod_flags() usable for GpioInt() gpiolib: acpi: Extract acpi_request_own_gpiod() helper gpiolib: acpi: Convert pin_index to be u16 gpiolib: acpi: Use BIT() macro to increase readability gpiolib: acpi: Make Intel GPIO tree official for GPIO ACPI work MAINTAINERS | 1 + drivers/gpio/gpiolib-acpi.c | 130 +++++++++++++++++++++--------------- drivers/gpio/gpiolib-acpi.h | 2 + 3 files changed, 81 insertions(+), 52 deletions(-) -- 2.28.0