On Thu, Jun 25, 2020 at 9:58 AM Sungbo Eo <mans0n@xxxxxxxxxx> wrote: > > NXP PCA9570 is 4-bit I2C GPO expander without interrupt functionality. > Its ports are controlled only by a data byte without register address. > > As there is no other driver similar enough to be adapted for it, a new > driver is introduced here. > > Signed-off-by: Sungbo Eo <mans0n@xxxxxxxxxx> Hi Sungbo, on top of Andy's review, here are some more nits I spotted. > --- > v2: > * move the direction functions below the set functions > * use devm_gpiochip_add_data() and remove the remove callback > > v1: > Tested in kernel 5.4 on an ipq40xx platform. > > This is my first time submitting a whole driver patch, and I'm not really familiar with this PCA expander series. > Please let me know how I can improve this patch further. > > FYI there's an unmerged patch for this chip. > http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/2017-May/105602.html > I don't have PCA9571 either so I didn't add support for it. > --- > drivers/gpio/Kconfig | 8 ++ > drivers/gpio/Makefile | 1 + > drivers/gpio/gpio-pca9570.c | 148 ++++++++++++++++++++++++++++++++++++ > 3 files changed, 157 insertions(+) > create mode 100644 drivers/gpio/gpio-pca9570.c > > diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig > index c6b5c65c8405..d10dcb81b841 100644 > --- a/drivers/gpio/Kconfig > +++ b/drivers/gpio/Kconfig > @@ -962,6 +962,14 @@ config GPIO_PCA953X_IRQ > Say yes here to enable the pca953x to be used as an interrupt > controller. It requires the driver to be built in the kernel. > > +config GPIO_PCA9570 > + tristate "PCA9570 4-Bit I2C GPO expander" > + help > + Say yes here to enable the GPO driver for the NXP PCA9570 chip. > + > + To compile this driver as a module, choose M here: the module will > + be called gpio-pca9570. > + > config GPIO_PCF857X > tristate "PCF857x, PCA{85,96}7x, and MAX732[89] I2C GPIO expanders" > select GPIOLIB_IRQCHIP > diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile > index 1e4894e0bf0f..33cb40c28a61 100644 > --- a/drivers/gpio/Makefile > +++ b/drivers/gpio/Makefile > @@ -110,6 +110,7 @@ obj-$(CONFIG_GPIO_OCTEON) += gpio-octeon.o > obj-$(CONFIG_GPIO_OMAP) += gpio-omap.o > obj-$(CONFIG_GPIO_PALMAS) += gpio-palmas.o > obj-$(CONFIG_GPIO_PCA953X) += gpio-pca953x.o > +obj-$(CONFIG_GPIO_PCA9570) += gpio-pca9570.o > obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf857x.o > obj-$(CONFIG_GPIO_PCH) += gpio-pch.o > obj-$(CONFIG_GPIO_PCIE_IDIO_24) += gpio-pcie-idio-24.o > diff --git a/drivers/gpio/gpio-pca9570.c b/drivers/gpio/gpio-pca9570.c > new file mode 100644 > index 000000000000..e6b6c4e791c0 > --- /dev/null > +++ b/drivers/gpio/gpio-pca9570.c > @@ -0,0 +1,148 @@ > +// SPDX-License-Identifier: GPL-2.0-only > +/* > + * Driver for PCA9570 I2C GPO expander > + * > + * Copyright (C) 2020 Sungbo Eo <mans0n@xxxxxxxxxx> > + * > + * Based on gpio-tpic2810.c > + * Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/ > + * Andrew F. Davis <afd@xxxxxx> > + */ > + > +#include <linux/gpio/driver.h> > +#include <linux/i2c.h> > +#include <linux/module.h> > +#include <linux/mutex.h> > + > +/** > + * struct pca9570 - GPIO driver data > + * @chip: GPIO controller chip > + * @client: I2C device pointer > + * @buffer: Buffer for device register > + * @lock: Protects write sequences > + */ > +struct pca9570 { > + struct gpio_chip chip; > + struct i2c_client *client; > + u8 buffer; Could you rename it to reg or something else more obvious? A buffer can be for anything. > + struct mutex lock; > +}; > + > +static void pca9570_set_mask_bits(struct gpio_chip *chip, u8 mask, u8 bits) > +{ > + struct pca9570 *gpio = gpiochip_get_data(chip); > + u8 buffer; > + int err; > + > + mutex_lock(&gpio->lock); > + > + buffer = gpio->buffer & ~mask; > + buffer |= (mask & bits); > + > + err = i2c_smbus_write_byte(gpio->client, buffer); > + if (!err) > + gpio->buffer = buffer; > + > + mutex_unlock(&gpio->lock); > +} > + > +static void pca9570_set(struct gpio_chip *chip, unsigned offset, int value) > +{ > + pca9570_set_mask_bits(chip, BIT(offset), value ? BIT(offset) : 0); > +} > + > +static void pca9570_set_multiple(struct gpio_chip *chip, unsigned long *mask, > + unsigned long *bits) > +{ > + pca9570_set_mask_bits(chip, *mask, *bits); > +} > + > +static int pca9570_get_direction(struct gpio_chip *chip, > + unsigned offset) > +{ > + /* This device always output */ > + return GPIO_LINE_DIRECTION_OUT; > +} > + > +static int pca9570_direction_input(struct gpio_chip *chip, > + unsigned offset) > +{ > + /* This device is output only */ > + return -EINVAL; > +} > + > +static int pca9570_direction_output(struct gpio_chip *chip, > + unsigned offset, int value) > +{ > + /* This device always output */ > + pca9570_set(chip, offset, value); > + return 0; > +} > + > +static const struct gpio_chip template_chip = { > + .label = "pca9570", > + .owner = THIS_MODULE, > + .get_direction = pca9570_get_direction, > + .direction_input = pca9570_direction_input, > + .direction_output = pca9570_direction_output, > + .set = pca9570_set, > + .set_multiple = pca9570_set_multiple, > + .base = -1, > + .ngpio = 4, > + .can_sleep = true, > +}; > + > +static const struct of_device_id pca9570_of_match_table[] = { > + { .compatible = "nxp,pca9570" }, > + { /* sentinel */ } > +}; > +MODULE_DEVICE_TABLE(of, pca9570_of_match_table); If you're not using it in probe than maybe move it next to the I2C device table? > + > +static int pca9570_probe(struct i2c_client *client, > + const struct i2c_device_id *id) > +{ > + struct pca9570 *gpio; > + int ret; > + > + gpio = devm_kzalloc(&client->dev, sizeof(*gpio), GFP_KERNEL); > + if (!gpio) > + return -ENOMEM; > + > + i2c_set_clientdata(client, gpio); > + > + gpio->chip = template_chip; > + gpio->chip.parent = &client->dev; > + > + gpio->client = client; > + > + mutex_init(&gpio->lock); > + > + ret = devm_gpiochip_add_data(&client->dev, &gpio->chip, gpio); > + if (ret < 0) { > + dev_err(&client->dev, "Unable to register gpiochip\n"); You don't need this message, the core library will print something for you. Just do return devm_gpiochip_add_data(). > + return ret; > + } > + > + return 0; > +} > + > +static const struct i2c_device_id pca9570_id_table[] = { > + { "pca9570", }, > + { /* sentinel */ } > +}; > +MODULE_DEVICE_TABLE(i2c, pca9570_id_table); > + > +static struct i2c_driver pca9570_driver = { > + .driver = { > + .name = "pca9570", > + .of_match_table = pca9570_of_match_table, > + }, > + .probe = pca9570_probe, > + .remove = pca9570_remove, > + .id_table = pca9570_id_table, > +}; > +module_i2c_driver(pca9570_driver); > + > +MODULE_AUTHOR("Sungbo Eo <mans0n@xxxxxxxxxx>"); > +MODULE_DESCRIPTION("GPIO expander driver for PCA9570"); > +MODULE_LICENSE("GPL v2"); > -- Bart