On Thu, Apr 16, 2020 at 01:56:14PM +0300, Andy Shevchenko wrote: > On Wed, Apr 15, 2020 at 08:15:16PM +0300, Serge Semin wrote: > > On Wed, Apr 15, 2020 at 05:15:34PM +0300, Andy Shevchenko wrote: > > > In some cases indentation makes code harder to read. Amend indentation > > > in those cases despite of lines go a bit over 80 character limit. > > > > + dev_err(dev, "missing/invalid port index for port%d\n", i); > > > > What about shortening the message text to fit the 80 chars per line rule? > > I suppose the "missing" word could be omitted. > > More likely port is not needed, but I think this kind of changes are material > for another (logically separated) patch. > > ... > > > > /* Mask out interrupts */ > > > - dwapb_write(gpio, GPIO_INTMASK, > > > - 0xffffffff & ~ctx->wake_en); > > > > > + dwapb_write(gpio, GPIO_INTMASK, 0xffffffff & ~ctx->wake_en); > > > > Hm, do I need some rest and missing something or the &-operation with 1s here > > does nothing seeing the operands data types have the same width? > > > > (the change introduced by commit 6437c7ba69c3 ("gpio: dwapb: Add wakeup source support")) > > No, you are right, it seems no-op to me, I have noticed it as well, but I think > we may improve this by separate change (as you seems also prefer not to mix > logically different changes in one patch). Ah, Linus already pulled the series in. Next time then.) Regards, -Sergey > > -- > With Best Regards, > Andy Shevchenko > >