Hi Bartosz,
Am 2020-03-18 10:14, schrieb Bartosz Golaszewski:
wt., 17 mar 2020 o 21:50 Michael Walle <michael@xxxxxxxx> napisał(a):
This adds support for the GPIO controller of the sl28 board management
controller. This driver is part of a multi-function device.
Signed-off-by: Michael Walle <michael@xxxxxxxx>
Hi Michael,
thanks for the driver. Please take a look at some comments below.
---
[..]
+#define GPIO_REG_DIR 0
+#define GPIO_REG_OUT 1
+#define GPIO_REG_IN 2
+#define GPIO_REG_IE 3
+#define GPIO_REG_IP 4
These values would be more clear if they were defined as hex.
+
+#define GPI_REG_IN 0
+
+#define GPO_REG_OUT 0
Please also use a common prefix even for defines.
The GPIO_, GPI_ and GPO_ prefixes corresponds to the different
flavours. Do they still need a common prefix? Ie. the GPI_REG_IN
has nothing to do with GPO_REG_OUT, nor has both something
to do with the GPIO_REG_IN and GPIO_REG_OUT. I could prefix them
with SL28CPLD_ though. But I don't know if that is what you had
in mind because then they would be SL28CPLD_GPIO_REG_IN and
SL28CPLD_GPI_REG_IN for example.
-michael