On Wed, Sep 04, 2019 at 04:01:04PM +0200, Linus Walleij wrote: > diff --git a/drivers/gpio/gpio-tqmx86.c b/drivers/gpio/gpio-tqmx86.c > index 07050cdbadb9..a3109bcaa0ac 100644 > --- a/drivers/gpio/gpio-tqmx86.c > +++ b/drivers/gpio/gpio-tqmx86.c > @@ -214,6 +214,17 @@ static const struct dev_pm_ops tqmx86_gpio_dev_pm_ops = { > tqmx86_gpio_runtime_resume, NULL) > }; > > +static void tqmx86_init_irq_valid_mask(struct gpio_chip *chip, > + unsigned long *valid_mask, > + unsigned int ngpios) > +{ > + /* Only GPIOs 4-7 are valid for interrupts. Clear the others */ > + clear_bit(0, valid_mask); > + clear_bit(1, valid_mask); > + clear_bit(2, valid_mask); > + clear_bit(3, valid_mask); > +} Hi Linus The change looks good. But a minor naming nit-pick. The code here assumes valid_mask has already been initialised, all valid gpios have had their bit set to 1 by the core. What we are actually doing here is masking the mask to fit the hardware. So maybe a better name would be tqmx86_mask_irq_valid_mask()? For gpio-tqmx86.c Reviewed-by: Andrew Lunn <andrew@xxxxxxx> Andrew