On Mon, 2017-10-09 at 13:42 +0200, Neil Armstrong wrote: > > +/* Common pmx functions */ > > +int meson_pmx_get_funcs_count(struct pinctrl_dev *pcdev); > > +const char *meson_pmx_get_func_name(struct pinctrl_dev *pcdev, > > + unsigned selector); > > +int meson_pmx_get_groups(struct pinctrl_dev *pcdev, > > + unsigned selector, > > + const char * const **groups, > > + unsigned * const num_groups); > > Maybe the naming of the common functions should be changed to something > generic > like meson_get_functions_name and meson_get_function_groups and leave "pmx" to > the > first version pinmux control implementation. > Same for the ops, meson_pinmux_ops would be better. I was thinking that the naming convention around this might be confusing. Thx for the confirmation ! However, I think "pmx" was intially meant to denote a pinmux function, since pinconf, gpio and pinmux are all mixed in pinctrl-meson.c. I'd prefer to keep this "pmx" for this reason. Maybe the SoC specific bits should be named after the first SoC supporting it: * files: pinctrl-meson-pmx.* => pinctrl-meson8-pmx.* * functions: meson_pmx_* => meson8_pmx_* What do you think ? -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html