Hi,
On 07-06-17 22:10, Sakari Ailus wrote:
Hi Andy,
On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote:
On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@xxxxxx> wrote:
On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote:
Follow the pattern, please, I suppose
ti_pmic_tps68470.c
This pattern is weird. "ti" in front of the file name is redundant, and in
very few places the vendor prefix is used anyway. Especially when the chip
has a proper name --- as this one does.
I assume for the Intel PMICs it could be there for a couple of reasons which
are
1) lack of a clearly unique chip ID and
2) the use of common frameworklet for Intel PMICs.
There are also no other PMIC chips supported currently.
The pmic_tps68470 naming is in line with the GPIO driver (apart from the
dash / underscore difference).
Since
% git ls-files *pmic*
returns somewhat interesting results, I would even go further and use
tps68470.c here
and
s/ti_pmic/tps6840/g
inside the file.
Would it work for you?
This is still a different driver from the tps68470 driver which is an MFD
driver. For clarity, I'd keep pmic as part of the name (and I'd use
tps68470_pmic_ prefix for internal symbols, too).
As PMICs are typically linked to the kernel (vs. being modules), there's no
issue with the module name. I would suppose few if any PMICs will be
compiled as modules in general.
Good point about the OpRegion driver usually being built-in, in my experience
it MUST always be built-in, so the Kconfig option should be a bool. Note this
is useless unless the mfd driver is also a bool (I would advice to go that
route) and the mfd driver's Kconfig should select the right i2c bus driver
to make sure that is built-in too, see for example:
https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for-mfd-next&id=2f91ded5f8f4fdd67d8daae514b0d434c98ab1e0
https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for-mfd-next&id=c5065d8625ebdc164199b99d838ac0636faa7f0b
https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for-mfd-next&id=5f125f1f570568a29edf783fba1ebb606d5c6b24
Which are all recent commits from me dealing with making the mfd driver
built-in / selecting the i2c bus driver.
Regards,
Hans
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html